No keyboard input on serial connection to MaiXDUINO with MaixPy

I just received a new MAiXDUINO board. When I try to connect to it over USB cable (/dev/ttyUSB0) I see the welcome message below but the prompt does not register any of my keyboard inputs.

      [MaixPy] sd_init | SD_CMD0 is FF

 __  __              _____  __   __  _____   __     __
|  \/  |     /\     |_   _| \ \ / / |  __ \  \ \   / /
| \  / |    /  \      | |    \ V /  | |__) |  \ \_/ /
| |\/| |   / /\ \     | |     > <   |  ___/    \   /
| |  | |  / ____ \   _| |_   / . \  | |         | |
|_|  |_| /_/    \_\ |_____| /_/ \_\ |_|         |_|

Official Site :
Wiki          :

MicroPython v0.3.2 on 2019-05-15; Sipeed_M1 with kendryte-k210
Type "help()" for more information.

I tried with 2 different linux machines, 4 different cables, 4 different terminals: screen (sudo screen /dev/ttyUSB0 115200), picocom, minicom, moserial and also on a windows 10 machine with puTTY. All exhibit the same behavior.

I find suspicious that the RX K210 LED is solid red all the time, even when powered through the DC plug. Is it normal?

I also tried to upgrade the firmware to MaixPy v0.4 with kflash_gui and kflash and it did not work. Kflash_gui says “attempting to use a port that is not open” and kflash says “No vaild Kendryte K210 found in Auto Detect, Check Your Connection or Specify One by -p /dev/ttyUSB0”.

I have documented the issues on the MaixPy github here and here.

Please help!

Can somebody please let me know if it is normal that the RX K210 LED is solid red all the time, even when powered through the DC plug and with no activity?

hi, the RX led should off when idle.
It seems CH552 circuit broken. you can try re-solder the ch552, or check if the RX pin short to some where.
If it is not work, please send your address to, we send new one to you

@zepan, I am facing similar issue.

is yours maixduino too?

@Zepan Yes, Maixduino.

@Zepan should I contact to

yes, it is ok

@Zepan I sent an email to and also cc’d you. I will appreciate your help on this issue.

I sent a mail to a few days ago referencing this thread but I have not received a response yet.

Please help.

@zepan Have you sent a replacement board to the address I provided?

@naveen Have you received your board or a tracking number?


@jeancf I have not received any tracking number or the replacement. I do not know if they have sent it or not. Have you got any confirmation that they have sent it? @Zepan, any updates?

@naveen I have not received any information from Sipeed support since I sent them my address.

@Zepan I have received a new kit today. It is working fine.

Thank you very much for your support!