Maixduino set up for Arduino and Windows

Myself and a colleague have been trying to load the Maixduino extension into the Arduino IDE (1.8.10 or 1.8.12) for Windows.
I have tried both of the suggested lines in Additional Boards Manager URL the file->preferences:
http://dl.sipeed.com/MAIX/Maixduino/package_Maixduino_k210_index.json
http://dl.sipeed.com/MAIX/Maixduino/package_Maixduino_k210_dl_cdn_index.json
When we try to install the Maixduino package in Tools->Board Manager, it fails while trying to load it, so it does not appear in the list of boards.

We have tried multiple times with only one success, that we have not been able to repeat.
Is there something going on with the website holding the .json files? Has anyone else had these problems and found a solution? Thanks!

It’s an absolute shambles, I am afraid. I have spent almost 8 hours today trying to make this work, and sort of have! But I don’t know if it’s really correct as I had to make a lot of assumptions!

There are all sorts of problems … incorrect filenames and hashes. I have cobbled together a set of files (from github, and also the Sipeed site) which at least allow you to install the board.Their MobileNet demo compiles and appears to load, but I just get “Loading …” on the LCD display. And a blinking LED on the board …

This is on Arduino Windows 1.8.12

Anyway … in Preferences -> Additional Board Manager add this line (which will not be there forever - the site is for something else!)

http://observat.io/MAIX/package_Maixduino_k210_index.json

Assuming this works (it did for me) you can search for MAIX in board manager, and install (there is only one version 0.3.13 which is newer than the versions on Sipeed – I found it in the Kendryte Github repo).

image

Horrible mess right now. I think the basic problem might be the CAPTCHA on the current Sipeed site …

Good luck!

Pat

Thank you kind Sir! It worked first time. I am going to set it up on another computer just to be sure.

I did get the “selfie” demo working but there was a change that had to be made in two files to get it to compile. I will try to reconstruct that and post it. Thanks again Pat!
Bill

Pat,
I’ve got this error message:
“CRC doesn’t match, file is corrupted. It may be a temporary problem, please retry later.”

Have you any idea about it?
I’m using Arduino IDE 1.8.12 under Ubuntu 20.04.
Regards!

Carlos

Yes, I have the same problem under Ubuntu 20.04.

Carlos

I have only set up the Windows stuff - sorry. The whole thing is a real mess and I’m not planning to have a go at Ubuntu, as it’s a) a load of work and b) I don’t have a way to test it anyway. I think we need to get Sipeed to fix their system. I have e-mailed their support , but no word yet.

For what it’s worth the general idea is to assemble all of the files (.zip files) along with the corresponding .json file and check that all of the filenames, SHA-signatures and file sizes correspond. And then stick them on a web server that you can point to. It’s a laborious process. And the error messages you get give no clue as to what is wrong (you generally just get a CRC error thrown in java).

Bill, what is the selfie demo !?

Pat

Under File->Examples->Sipeed_OV2640->selfie
Shows live video from the camera to the LCD screen
Also Sipeed_ST7789->basic_display
Does some graphics and a rotating screen

Thanks again Pat.

With the URL that you gave me, selfie and basic_display compiled without error.

Great. Thanks, There was a selfie script on the board when I got it actually – some nifty timing on the button pushes on startup got it to load. It’s gone now - replaced with the (non-working I think) MobileNet demo … which does actually compile fine but I’m not sure if it works or not - I cannot get it to!

I tried both of the touchscreen examples and neither worked on my unit. Both programs compiled and downloaded fine, just no response to any touches.

Has anyone gotten the Maixduino touchscreen examples to function?

Did you have to alter the selfie sketch? I get nothing on the LCD (apart from the RED) and serial debug is full of “snap fail” messages :frowning:

Thanks

Pat

ps. thanks, I actually did not realise it had installed Examples (even if they mostly don’t work!)

No, it compiled and downloaded and ran with the URL you supplied. But I think I know what is going on. I got two kits, one for my summer intern and one for myself. One had a camera with an inch long flex, the other had a much shorter flex, less than a half inch. The long camera would not work with selfie (snap fail) but the short camera ran fine. My guess is those are two incompatible modules and you have to reference a different camera type for the long flex variety… bizarre they are randomly shipping out different cameras.

Only the short one on top works for selfie. Two boxes two different cameras. If anyone can identify the lower camera, that would be great.

I am not the only one with this issue either.

Interesting, I have the one with the longer cable. Out of the box, there was a selfie sketch installed which worked. You accessed it by pressing the right hand button for just the right amount of time after boot. That sketch is now gone after all my playing! I wonder how you get the shorter cable camera?

I sent a question to support@sipeed.com about which camera is the long cabled version. If they could tell us the camera type and which driver to use, we could obviously change selfie and other programs to work with it…

It’s the simple things…

Perhaps this is the same reason that I cannot get the MobileNet demo to play along?!