Dead k210?

Getting a stack dump (below) when trying to connect to MAix Go Board. It was working, stopped all of the sudden somewhat after a flash of a kmodel to 0x00300000

Seeing this error during telnet, kflash, pio, and ampy. Have tried dismantling the board, cycling power, and rebooting.

According to the source code, it should be giving me a reason, it is not.

Cause 0x0000000000000002, EPC 0x0000000080000006, Core 0
reg00 = 0xc34274781623e610, reg01 = 0x000000008800b32c
reg02 = 0x00000000805ffdd0, reg03 = 0x00000000805fc800

<BBB is not letting me post the entire stack dump, saying “new users can only post max of 5 links”, I am not posting any links>

(Stack Dump Continues Here)

Reason: f?ck the chip is dead!
Reason: f?ck the chip is dead!
interesting, something’s wrong, boot failed with exit code 666, go to find your vendor.

It only means the flashed application (in SPI Flash) is corrupted.
Reflash and all will work again…

I know I tried to flash it several times before, this time it worked using kflash_gui. Thanks!