Timeout Error on upload in Arduino IDE to MAIXduino

For all MAIXduino users trying to upload code to the board from Arduino IDE…
I have struggled with the following errors popping up 99 times out of 100 uploads:
[INFO] FT2232 mode
Downloading ISP: |=============================================| 100.0% 62kiB/s
[INFO] Booting From 0x80000000
[INFO] Wait For 0.1 second for ISP to Boot
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
[WARN] Timeout Error, retrying…
‘MAIXLoader’ object has no attribute ‘raise_exception’
the selected serial port ‘MAIXLoader’ object has no attribute ‘raise_exception’
does not exist or your board is not connected

My final solution was to add the -S SLOW parameter to kflash. Uploads take a tiny bit more time but at least it works.
I use linux, there you add the parameter in the file
/home//.arduino15/packages/Maixduino/hardware/k210/0.3.9/platform.txt
Open this file with an editor, scroll down to # Uploader tools,
add the parameter to this line:
tools.kflash.program.pattern={cmd} -n -S SLOW -p {serial.port} -b {build.burn_baudrate} -B
Save the file and RESTART ARDUINO IDE in order to make the change effective.
(Windows users : your file location may differ and you will have to change the line with tools.kflash.program.pattern.windows )