MAIX Bit v2.0 Windows 10 x64 not recognized and cannot install drivers

When I plug my MAIX Bit v2.0 with CH552 and Microphone into my Windows 10 64bit machine, I get the following entry in device manager:

“Unknown USB Device (Device Descriptor Request Failed)”

I attempted to install FT2232 drivers (as loosely suggested here: [https://maixpy.sipeed.com/en/get_started/install_driver.html](http://maixpy install driver)), but that didn’t work.

I did all the usual things. Uninstalled the device in device manager, rebooted, tried multiple driver installations, and nothing works.

Is there any clear documentation about how to get this device working on Windows 10 64bit? Or is my device broken? If it’s broken, how can I get it replaced?

Windows USB Device Viewer gives me the following information, in case it’s helpful:

[Port2] FailedEnumeration : Unknown USB Device (Device Descriptor Request Failed)

Is Port User Connectable: yes
Is Port Debug Capable: no
Companion Port Number: 0
Companion Hub Symbolic Link Name:
Protocols Supported:
USB 1.1: yes
USB 2.0: no
USB 3.0: no

   ---===>Device Information<===---

ConnectionStatus: FailedEnumeration
Current Config Value: 0x00 -> Device Bus Speed: Low
Device Address: 0x00
Open Pipes: 0
*!*ERROR: No open pipes!

      ===>Device Descriptor<===

*!*ERROR: bLength of 0 incorrect, should be 18
bLength: 0x00
bDescriptorType: 0x00
bcdUSB: 0x0000
bDeviceClass: 0x00
*!*ERROR: Device enumeration failure

There is no issue with my cable, I’ve verified that the USB cable I am using is fine (it works with my phone and can transfer data with it).

After trying for 3 days to get my device recognized in windows, I think I can safely say that I got a dud. It is definitely not working. My cable is fine, I’ve installed the right drivers, and the only thing that is consistent, is that my MAIX Bit v2.0 won’t recognize. Is there some kind of warranty I can use to get a replacement? Have many other people been sold dud devices?

You probably need to reflash the CH552 Firmware.
You will propably need ch552tool, I think you can install it with pip.

Thanks @loboris but why? It’s a brand new device? Why would it need reflashing? And how do I reflash it? It’s difficult since there’s basically no useful documentation for the MAIX Bit at all.

Thanks.

I just read through the links you provided. I’ll try it again later this week.
I feel like it might even by my computer though. I have the Intel ICH10 chipset which seems to have issue with some USB devices. At this point I’m not sure what to try next.

CH552 firmware may be damaged, or it was not correctly flashed before shipping.
I don’t have maix-bit with CH552, but the flashing should not be the problem using ch552tools.
I doubt the problem is on your PC, but maybe you could try it on another one?

You could look at sipeed Telegram channel, there is some information about your issue there…

You could also try it on a Linux PC (or on Linux virtual machine in VirtualBox).

1 Like

If the firmware wasn’t flashed, or is damaged, that doesn’t say much for Sipeed’s quality control…

Hello,

I had exactly the same problem and spent a lot of time trying to resolve it. The solution is to purchase a powered USB hub and connect the Maix Bit V2 to the PC via the powered USB connection, the drivers will then load correctly and everything will work as described in the Sipeed website.

My Maix Bit did work with my laptop until I had a Windows 10 update and then it just refused to recognise the drivers. The problem only seems to effect some PCs and laptops, as my Maix Bit is working fine on other windows 10 machines running the same version of software.

IKNA

1 Like

Thanks for the info @ikna, do you think this is due to a CH552 driver issue or a hardware issue? Are you aware if anyone is working on a fix for this? Thank you kindly.

No. I believe it is a windows issue. I only found the solution by searching the internet. It seems to be a fairly common problem. My BIT worked okay on an older Windows XP machine and a brand new laptop running Windows 10, but would’nt work with with my laptop after it had a Windows 10 update.
I bought a powered USB hub from Curries, used it with my laptop and BIT and it immediately started to work.

1 Like