Lichee Pi Nano - pinout

Hi, I started playing with Nano board (SPI flash version). I’m trying to put there u-boot via UART0 pins. I have a problem with finding them. I tried to connect to pins probably marked as UART’s RX/TX, but I cannot communicate through them. Silk screen marking are a little bit confusing, to I tried to find a pinout diagram.
I have found this one (lichee_nano_new.pdf):

But now I’m even more confused. Maybe I’m reading it wrong, but for me looks like the UART0 is located on opposite side than marked on PCB.
Where I need to connect to access UART0 TX/RX pins?
And also - does someone have “nice&clean” Lichee Pi Nano pinout diagram?

Thank you

Hi,I uploaded an accurate picture.Please try it.

Thank you

Thank you, so looks like the silk screen markings were correct from the start.

Unfortunately it does not help me with my problem. My goal is to connect with device in FEL mode and flash U-boot into it. When I plug in Nano through micro-usb to my computer, the “lsusb” command show no new device (“dmesg” neither). Then while google-translating the documentation from Chinese I found a mention about UART0. But that port is silent, also sunxi-fel tool cannot recognize it.
I feel like I’m missing something. How to make Nano report to my computer in FEL mode?

I think I kinda managed to make it work, or at least now I understand whats going on. I’ve got the boards with preflashed with u-boot and Linux 4.15. I’m getting a bootlog via UART0. Everything fits on 16MB flash memory, its quite impressive tbh.

Now I want to be able to repeat all those steps to be able to build and flash there my own Linux instance. But thats question for another topic. I will come back here if stuck :wink:

The above link is dead please post a file that has the linux 4.15 and uboot files. Thank you