MaixPy IDE no frame buffer display in windows.

Hi,
I am using the M1w dock with IDE 0.2.2 under windows 10. Programs seem to run fine but I cannot get the IDE video to work.

I’ve tried firmware maixpy_v0.3.2_full.bin and maixpy_v0.3.2_no_lvgl.bin.

Also tried the IDE in Ubuntu 16.04, same result, programs run but no IDE video.

I’ve noticed that when running the helloworld default example, only the first 4 or so FPS are printed out in the serial terminal but video continues on the LCD screen of the dock.

Is this a firmware issue or do I need to enable something I’ve missed.

Thanks.

Same problem here. I am using M1w dock with IDE 0.2.3, firmware maixpy_v0.4.0_9 under MACOS 10.12.6. Any help would be appreciated.

Looks like it’s an AMD issue from my end. I have an old Intel laptop which I tested the ide on since my first post and video in the ide worked fine. But my AMD desktop still gives no frame buffer display in either Ubuntu or win 10 (using latest mater firmware and ide 2.4). Maybe something to do with the way the AMD chipset handles USB.

thanks for the thorough update^^